ubuntu apt-get 报错

今天想要用apt-get安装一个新的包的时候,遇到个错误

<pre>root@W-8Y1BR32:/mnt/c/django# apt-get install wget
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: The package atom needs to be reinstalled, but I can’t find an archive for it</pre>

 

网上找了下原因可能是由于之前安装包,失败造成的

 

编辑/var/lib/dpkg/status

 

找到之前的包atom,可以看到下面的信息

<pre>

….

Package: atom
Status: install reinstreq half-installed
Priority: optional
Section: devel
Architecture: amd64
Version: 1.18.0

….

</pre>

 

直接删除这段内容,然后再次尝试apt-get ,一切正常。

 

加班不给钱