python excel 配对

from openpyxl import load_workbook
import shutil


comparebook = "2.XLSX"
comparebook2 = "Device List 20190603.xlsx"

wb = load_workbook(comparebook)
wa = load_workbook(comparebook2)
sheet_a = wb['Sheet1']
sheet_b = wa['PCs']

dict = {}
dictb = {}
vat_n = 2
while vat_n <= sheet_b.max_row :
    a = sheet_a.cell(row=vat_n, column=7).value
    b = sheet_a.cell(row=vat_n, column=1).value
    try:
        dict[a.rstrip()] = b.rstrip()
    except:
        print("找不到序列号")

    vat_n +=1

nu = 2
while nu <= sheet_a.max_row:
    q = sheet_a.cell(row=nu, column=6).value
    sheet_a.cell(row=nu, column=1).value = dict[q]

    nu +=1


wb.closed()
wc.save("Device List 20190612.xlsx")

print("匹配完成!请打开:2.XLSX")

在使用Zabbix 时出现,图表中的文字无法正常显示。

在使用Zabbix 时出现,图表中的文字无法正常显示。

在查阅后,得出需要检查的地方有两个:

  1. /usr/share/zabbix/fonts/ 这个地方时存放zabbix前台显示的字体文件的,文件以ttf为后缀。
  2. /usr/share/zabbix/include/defines.inc.php 这个文件是zabbix 的配置文件。
define('ZBX_GRAPH_FONT_NAME',       '字体文件名'); // font file name
define('ZBX_FONT_NAME', ' 字体文件名 ')

ubuntu apt-get 报错

今天想要用apt-get安装一个新的包的时候,遇到个错误

<pre>root@W-8Y1BR32:/mnt/c/django# apt-get install wget
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: The package atom needs to be reinstalled, but I can’t find an archive for it</pre>

 

网上找了下原因可能是由于之前安装包,失败造成的

 

编辑/var/lib/dpkg/status

 

找到之前的包atom,可以看到下面的信息

<pre>

….

Package: atom
Status: install reinstreq half-installed
Priority: optional
Section: devel
Architecture: amd64
Version: 1.18.0

….

</pre>

 

直接删除这段内容,然后再次尝试apt-get ,一切正常。